EASy68K  
It is currently Sun Jul 05, 2020 11:59 pm

All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Apr 16, 2020 2:52 pm 
Offline

Joined: Thu Feb 16, 2012 4:34 pm
Posts: 21
I am running a firmware-emulation of a single board computer in Easy68k, the host computer is connected via RS232 (19200,8,n,1)
The emulating PC runs Windows 10, the host XP.
The host and the SBC (PCB) are working perfectly together.

Also the emulation works quite fine - except that the handshake between both PCs does not seem to work, and the Easy-Traps (#40-42) do not allow to set it up (hardware, xon/xoff etc.)
So my emulation is overrun with the first characters sent by the hosts and thus both, host and emulation, get confused and cannot properly connect.

Moreover, transmit ans receive buffering on side is weird. Characters are never lost, but sometimes cannot be received as they com but are released later etc.
I have already tried anything I could think of but so far could not find a clear, stable workaround.

My initial questions are:
- How exactly does Easy68k-Trap #40 and #41 configure the RS232-interface wrt to handshaking?
- How can I set up any type of handshake which indicates "busy" to the other side?

Thanks in advance.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group